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Using QuPath to analyze RNAscope™, BaseScope™ and
miRNAscope™ images

Introduction

QuPath, short for Quantitative Pathology, is a free open source bioimage analysis software for whole slide images
developed by Bankhead et al. at the University of Edinburg. This guide introduces the basic workflow for quantifying images
from chromogenic RNAscope™ assays (Cat. No. 322300, 322350, 322430, 322100, 322150, 322440, 323200,
323250, and 323300), fluorescent RNAscope™ assays (Cat. No. 320850, 323100, 322800, and 324100), chromogenic
BaseScope™ assays (Cat. No. 323900, 323600, 323700, and 323800), and chromogenic miRNAscope™ assays (Cat. No.
324500 and 324600) using QuPath.

Installing the software

1. Use the following link to download the latest, stable version of the QuPath software: https://qupath.github.io/. The
latest version is v0.2.3 as of this writing.

2. For versions 0.2.0 and earlier, install the QuPath Bio-Formats extension https://github.com/qupath/qupath-bioformats-
extension fo enable opening of additional file formats, such as .qptiff from Polaris and .czi from Zeiss.

3. Under Preferences, adjust the following:

B Preferences O x

e For quantification, you should use at least 40X magnification to acquire all RNAscope ", BaseScope™, and

. ™ , . . .
miRNAscope  images or whole slide scans. Use uncompressed images for analysis.

e Some of the modules used in these instructions are still experimental, such as the subcellular defection module. This
technical note provides a general workflow for the most recent stable release, as well as workarounds to analyze

ISH images using current modules. As the software develops, these modules will be updated.

e We recommend viewing QuPath’s documentation and introductory video tutorials
(https://www.youtube.com/c/QuPath/playlists) to familiarize yourself with the software.
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Chromogenic RNAscope™ and BaseScope™ image analysis

Singleplex chromogenic images

The following steps describe a general workflow for analyzing singleplex chromogenic RNAscope™ or BaseScope™ images.
We recommend creating a project for your images before you begin the analysis so you can save the analysis settings and

annotations for all the images in the project to the project folder.

Image tab changes

1. To create a project, go to File = project = create new project and select a folder to save this project.
2. Import your images using File > open or by dragging the files onto QuPath’s main window. You can see the list of

your images under the project tab.
3. Set the image type to Brightfield (other) as shown in the following figure.

mage provider | Default (et QuPath decide)
Set image type  Brightfield (other)

Rotate image
v Auto-generate pyramids
Import objects

Choose files nput URL From clipboard From path list

Import Cancel

4. Double click an image in your list to open it in the viewer.
5. To change the stain name based on your probe, go fo the Image tab.
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6. Find the stain name field in the list of image properties, and double-click the field to change the name. See the
following figure for an example.

Project | Image | Annotations | Hierarchy | Workflow

Name
Name
URI
Pixel type
Magnification
Width
Height
Dimensions (CZT)
Pixel width
Pixel height
Uncompressed size
Server type
Pyramid
Metadata changed
Image type
Stain 1
Stain 2
Stain 3

Background

QuPath Analysis Guidelines

Value

singleplex_red.svs

file:/D:/Qupath Demo/singleplex_...

uintd (rgb)

400

103584 px (26061.72 pym)
65092 px (16377.15 pm)
3x1xl

0.2516 pm

0.2516 pm

18.8 GB

OpenSlide

141632

No

Brightfield (other)
Hematoxylin: 0.651 0.701 0.29
Probe 1: 0.269 0.568 0.778

255 255 255
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To analyze the image, perform a color deconvolution to separate the nuclei and the probe stain, then use the results to
segment the nuclei and probe. Carefully select stain values as this step directly impacts the segmentation step.

1. To select the stains, use the Rectangle annotation tool to select an example Hematoxylin stain in your image. Make
sure the chosen area does not contain any probe signal.

2. To set the average color of the selected area to the “Stain 1” color vector, double click on the Stain 1 field, and click
OK to confirm.

[ e i ol

File Edit Tools

View Objects TMA  Measure

Automate  Analyze Classify Extensions Help

B (= B)elldic] (] All2] [0] 200 [a] [BEE = — o0 (2] EMEBE=] o L

Project | Image | Annotations | Hierarchy | Workfiow = I

¥ Properties
Name Value i
. Name . singleplex_red l |
Path D\Qupath Demo\singlep.
Image type Brightfield (other)
Bit depth 8-bit (RGB)
Magpnification 40.0
Width 103584 px (26061.73 pm)
Height 65092 px (16377.15 pm)
Pixel width 0.2516 pm
. Pixel height 0.2516 pm
Server type OpenSlide
‘Stain 1 Hematoxylin: 0.651 0.701...
Stain 2 Probe 1: 0.269 0.568 0.778
Stain 3
Background 253 235 255

QuPath Analysis Guidelines

Q Color deconvolution stains

Set stain vector from ROI?

Lo ]| n
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3. Repeat steps 1 and 2 to select the probe stain. Find an area where the hematoxylin signal does not blend with the
probe stain.

File Edit Tools View Objects TMA  Measure Automate Analyze Classify Extensions Help

S| | @ 32000 & | (B8] 8]

& Eoleldle & ls

Project | Image H Annotations H Hierarchy || Workflow @

¥ Properties

Name Value
MName singleplex_red
Path D:A\Qupath Demo\singlep...
Image type Brightfield (other)
Bit depth 8-bit (RGB)
Magnification 40.0
Width 103584 px (26061.73 pm)
Height 65092 px (16377.15 pm) )
Pixel width 0.2576 pm
Pixel height 0.2576 pm
Server type OpenSlide
Stain 1 Hematoxylin: 0.638 0.641...
Stain 2 Probe 1: 0.269 0.568 0.778
Stain 3
Background 255 255 255

Note: You can also add stain values manually if they were previously recorded for similar images. Double-click the stain
field and enter the values.
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4. To perform the next steps, QuPath requires you fo select a region using any of its annotation tools (see the following
figure as an example). To analyze the whole slide, you must annotate the whole tissue.

LS

Project | Image | Annotations | Hierarchy | Workflow ~ | | 4

o
e B

7 ARG
B

e B
LN
""!//;‘f_/’"ﬁ"'
: eaer Byt
-~ . ~

* Properties
Name Value
Name singleplex_red
Path [\Qupath Demo\singlep...
Image type Brightfield (other)
Bit depth 8-bit (RGE)
Magnification 100
‘Width 103584 px (26061.73 pm)
Height 65092 px (16377.15 pim)
Pixel width 02516 ym
Pixel height 02516 ym
Server type Openslide
Stain 1 Hematoxylin: 0.688 0.602...
Stain 2 Probe 1: 0,404 0.702 0.586
Stain 3
Background 255255255
Cell segmentation

Ty 3 -

3 : =
S o ﬁ;&
PN £

P

R 5
AN =y

i
4

5 45‘, o ,f

1. To perform cell segmentation, go to Analyze > Cell detection - Cell detection.

TMA  Measure

Automate

IGELC  Classify  Extensions  Help

We)a &) (s)

;‘ Workflow

Value

aplex_red.svs
x/Qupath Demo/singleplex_...
(rgb)

84 px (26061.73 pm)
2 px (16377.15 pm)

x1

6 um
6 um

QuPath Analysis Guidelines

"
-y

Preprocessing

Tiles & superpixels
Cell detection

r Calculate features
- Spatial analysis

Interactive image alignment
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2. Select the default settings as shown in the following figure.

BT Watershed cell detection

Setup parameters

Requested pixel ... | 0.5

Nucleus parameters

Background radi... | 8

Median filter rad... | 0

Sigma 1.5
Minimum area 10
Maximum area 400

Intensity parameters
Threshold 0.1
Max backgroun... | 2
/| Split by shape

Cell parameters

Cell expansion

v Include cell nucleus

General parameters
v'| Smooth boundaries
v'| Make measurements

QuPath Analysis Guidelines

Choose detectio... | Hematoxylin OD

um

pm
pm
pm
pumA2

umA2

Run

|

5pm

bad
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3. Visually inspect the results of the segmentation

s TMA Measure Automate Analyze Classify Extensions Help
&l [s]le] (0] 2 [ [E)EE = Ola| FEFEE 2| (e 4

Value

red

1 Demo\singlep...
1 (other)

bl

«(26061.73 pm)

(16377.15 pm)

1

Ain: 0.688 0.602...
1.404 0.702 0.586

55

R e NSRBI Doy s

o,

4. To improve results, do the following:

To remove noise, select a median filter option.
e To capture more faintly stained nuclei, increase the background radius parameter.
To adjust the resolution at which the images are being processed, change the requested pixel size parameter to

match the native image resolution.
A detailed explanation of these parameters can be found in this video.
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1. For probe detection, go to Analyze - Cell detection - Subcellular detection (experimental).

1A Measure Automate Classify  Extensions Help

SN S S Preprocessing .j@@ = mv

" Tiles & superpixels

‘orkflow
Cell detection
Value
| Calculate features ;
red.svs Cell detection

path Demo/singleplex_...
Interactive image alignment

Spatial analysis * | Positive cell detection

A A

Fast cell counts (brightfield)

Subcellular detection (experimental)

Deprecated

(26061.73 um) -

2. Adjust the detection threshold interactively. Start with one value and inspect the results; then, adjust until all the

probe dots are defected. See the following for example parameters.

B 1 Subcellular spot detection O

Detection parameters

Detection threshold (Probe 1)

Smooth before detection
v'| Split by intensity
Split by shape

Spot & cluster parameters

Expected spot size 0.5 pm#2
Min spot size 0.5 pm~2
Max spot size 2 pm#2

v'| Include clusters

Run

QuPath Analysis Guidelines
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A zoomed example of probe detection (pink circle) is shown in the following images.

QC probe defection resulls

1. During the process of optimizing the probe detection parameters, inspect the results of the detection by using Show
detection measurements.

- Show TMA measurements

i Show annotation measurements

Show detection measurements
e 1

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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A table of cell by cell measurements results, including the number of probe copies detected within each cell. For an
example, see the following highlighted measurement for a cell with two probe copies.

B | Detection results - singleplex_red [m} b
iper Cell: Eccentricity Nucleus/Cell area ratio Subcellular: Probe 1: Num spots estima... Subcellular: Probe 1: Num single sp... Subcellular: Probe 1: Num clust... Num spots Subcellular cluster
0653 0374 0 0 0 3
0.765 0.167 2 2 0
1 0.
1 0.
0.542 0.367 2 2 0
1 1.8
1 0.
0.783 0.187 0 0 0
0.639 0.305 4 4 0
1 0.5
1 0.
1 0.
1 1e
0.678 0.183 4 4 0
1 0.
1 0.5
1 0.
1 0.¢
7 neis (AN 1 1 n = 3 v
Column filter
Show histograms Copy to clipboard Save

2. Double-click on a measurement in the table to highlight the linked cell in the image.
3. Compare the number of detected probes in the table to the number of copies seen visually in the cell and change
the parameters until they match.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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Measurements

The cell measurement table allows you to view the measurements as histograms for the whole region (see the following
example).

B | Detection results - singleplex_red O s
ame ZEE ROl v R O e T Subcellular: Probe 1: Num spots estimated -

PathCellCbject Polygon 16666.6 13021.9 .

PathCellObject Polygon 16890 13022.2

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16892.5 13024 500

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16885.9 13024.6 i

PathCellObject Polygon 16856.3 130224 600

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16852.2 13020.5 g 500

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16855.6 130231 é 400

PathCellObject Polygon 16918.9 13022.9

PathCellCbject Polygon 16845.3 130231 e

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16850.5 13019.5 200

Probe 1 object  Subcellular spot: Probe 1 object  Rectan... 16844.6 13021.3 100 7]

Probe 1object  Subcellular spot: Probe 1 object  Polygen 16851.1 12021.2 0 [ = 1 = T P T T T

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16848.8 13027.2 0 3 weonow s W VaTLSJes Wm0 s s

PathCellObject Polygen 16782.3 13023.1

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16780.1 13021.2 R Measurement Value R

Probe 1 object  Subcellular spot: Probe 1 object  Polygon 16780.3 130224 /| Draw grid Count 1350

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16779.7 13025 v | Draw axes Missing AL

Probe 1object  Subcellular spot: Probe 1 object  Polygon 16779.8 13026.7 Number of bins 22 :‘::;ﬂ ::;‘f:

(D:H—\rn\lﬂhiurl Dnhrnn 1R024 @ 12022 7 5 e Animate changes Min 0

Column filter < ks )

I Show histograms I Copy to clipboard Save

You can export the results by selecting the table and copying to other data analysis tools, such as an Excel spreadsheet,
for further analysis.

Scripting the workflow

In QuPath, you can convert your workflow into a script. This allows you to easily apply the same workflow to other images
in your project or other regions of interest within the same image.

1. To create a script, choose Create a workflow from the workflow tab. A window appears with a list of processing
steps. QuPath records all optimization steps as separate steps in the workflow.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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2. For each processing step, keep the parameter that gives the best results and delete the others. The workflow should
look like the following figure.

B | Workflow [} X
Set image type
Set color deconvolution stains

Watershed cell detection

Subcellular spot detection

Parameter Value

No content in table

Create script

3. Click on Create script, and save the results using File - save.

4. (Optional) To visually classify the cells based on expression levels, add setCelllntensityClassifications("Subcellular: Probe
1: Num spots estimated”, 1, 4, 10) to the end of the script. This will classify the cell into three colors/classes. The
numbers represent expression levels of 1+, 4+ and 10+ probe copies per cell

5. Apply the script to other regions using Automate > show script editor > Run.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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Duplex chromogenic images

The workflow for analyzing duplex images follows the same basic steps for analyzing singleplex chromogenic images. The
changes that need to be considered at each step are explained.

Stain vecfor selection
1. After selecting the stain vector for the first probe, follow the same steps to select a stain vector for the second probe.

For duplex analysis, focus on finding the optimal separation between the two probes. You can ignore the nuclear
stain vector selection or assign it to a color that is completely different from the colors assigned to the probe stains,
as long as separation of the two probes have been optimized.

Note: This is an optional choice. However, QuPath will be more efficient at separating the probes from each other if the
nuclear stain vector is completely different from the two probes.

Pyramid 1416 46.7
Metadata changed Mo
Image type Brightfield (other)
ET Hematoxylin: -0.304 -0.183 0.935
Stain 2 Probe 1: 0.727 0.589 0.352
Stain 3 Probe 2: 0.636 0.692 0.342
Background 255 255 255
QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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Cell segmentation

1. Use Optical density sum to segment the nuclei. You can adjust other parameters to optimize the segmentation as
previously described for singleplex chromogenic images and as shown in the following figure:

B Cell detection O =

Setlup parameters

Detection image Orptical density surm -

Requesied pieel size 0.5 jam

Mucleus parameters

Background radius | Bm
Median Mier rades (4] jam
Sigma 1.5 pm
Minimum area 10 pmtd
AP ATea 400 pma g

Imtensity parameters

Threshald o1

Max Background infensity | 2

W | Split by shape

Cell parameters

Cill expansion 5 pm
v | Indude cell nucleus

General parameters

wW | Smanlh bound ares

| Make measurements

i

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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Probe defection

1. If needed, adjust the threshold parameter for the second probe in the subcellular cell detection module. See Cel/
segmentation on page 6 to change the two values interactively until both probes are detected appropriately.

B | Subcellular spot detection m| X
Detection parameters

Detection threshold (Probe 1) | 0.2

Detection threshold (Probe 2) | 0.35

N Smooth before detection

Split by intensity
Split by shape

Spot & cluster parameters

Expected spot size 1 pm#2
Min spot size 0.5 um*2
Max spot size 2 pm#2

v Include clusters

Run

Measurements

For duplex analysis, the measurement table contains extra columns for probe 2 results.

Chromogenic miRNAscope™ image analysis

Expression in the miRNAscope™ assay is typically in the form of small puncta that can form relatively big clusters (see the
following image). You can use the alternative mean optical density method to relatively quantify miRNAscope™ assay
samples.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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Step summary

1. Follow the color deconvolution steps used for the singleplex assay to select stains for the nuclei and probe of
interest.

2. Use the positive cell detection module to show cell classification based on expression level. This module directly
visualizes expressions of different levels and can also export the class of each cell based on expression level.

Automate Classify  Extensions Help

o S Preprocessing 4 @) (| 83 I ai‘ | a° ‘ (& |
™ Tiles & superpixels B \ ﬁ S\

| Cell detection i Cell detection
| Calculate features il Positive cell detection &

; Spatial analysis f

' Subcellular detection (experimental)

Fast cell counts (brightfield)

HD?precated_ 'w F s &
M pr—" . R 3K

Note: If you only want fo export the mean optical density value per cell, you can use the typical cell detection module
described previously.

3. Use the positive cell detection module. This module simultaneously allows the segmentation of cells and the ability to
classify the cells based on the mean optical density of the signal of interest.

B Positive cell detection o &

Nucleus parameters
Background radius 8 pm
Median filter radius 0 pm
Sigma 15 pm
Minimum area 10 pmA2

Maximum area 400 umA2

Intensity parameters

Threshold 0.1

Max background intensity | 2

v Split by shape

Cell parameters

Cell expansion 5 ym

V| Include cell nucleus

General parameters
v Smooth boundaries

v Make measurements

Intensity threshold parameters

Score compartment Cell: miRNA OD mean -
Threshold 1+ 0.05

Threshold 2+ 0.1

Threshold 3+ 0.15

Single threshold

4. Adjust the cell segmentation parameters using the guidelines in the chromogenic analysis section. Within the same
window, choose Cell: probe_name OD mean as the scoring method under Intensity threshold parameters. Probe name is
miRNA in the preceding example.

5. The module allows you to set three threshold values that classify cells into four classes based on expression level. The
threshold values are chosen experimentally and need to be adjusted for the expression levels in your images. To
relatively compare results, keep the threshold values consistent across all images within an experiment.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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The values chosen in the preceding example will classify the cells into 4 classes:

Negative if less than 0.05

e 1+if>0.05and <0.1
e 2+if>0.1 and <0.15
e 3+if>0.15

The following cell is classified in the 3+ class with a mean optical density of 0.243 (greater than a threshold of 0.15):
Key Value = : o W

Image Hela-miR21.svs

Name 3+

Parent PathAnnotationObject
ROI Polygon
Centroid X pm 2515.4269
Centroid ¥ pm 1816.7435
Nucleus: Area 108
Nucleus: Perimeter 40.4309
Nucleus: Circularity 0.8302
Nucleus: Max caliper 13.9362
Nucleus: Min caliper 10.503
Nucleus: Eccentricity 0.564
Mucleus: Hematoxylin OD m... 0.1399

Cell: Min caliper 18.3911
Cell: Eccentricity 0.6245
Cell: Hematoxylin OD mean 0.0142
Cell: Hematoxylin OD std dev  0.1405
Cell: Hematoxylin D max 0.3306

Cell: Hematoxylin OD min -0.638

Cell: miRNA OD std dev 0.2023

Cell: miRNA OD max 1.3058
Cell: miRNA CD min -0.0263

Cytoplasm: Hematoxylin OD ... -0.0529
Cytoplasm: Hematoxylin OD ... 0.1258 .

The following cell is classified in the 2+ class with a mean optical density of 0.148 (greater than a threshold of 0.1 and less
than a threshold of 0.15):

Key Value

Image Hela-miR21.svs

Name 2+

Parent PathAnnotationObject
ROI Polygon
Centroid X pm 2503.6001
Centroid ¥ um 1808.5043
Nucleus: Area 78
Nucleus: Perimeter 331644
Nucleus: Circularity 0.8912
Nucleus: Max caliper 10.881
_ Nucleus: Min caliper 9.8202
| Nucleus: Eccentricity 02793

" Nucleus: Hematoxylin OD m... 0.2212

Cell: Max caliper 18.7821
Cell: Min caliper 14.8492
Cell: Eccentricity 0.546

Cell: Hematoxylin OD mean 0.0615
Cell: Hematoxylin OD std dev  0.1602
Cell: Hematoxylin OD max 0.5156
Cell: Hematoxylin OD min -0.4846

Cell: miRNA OD mean

Cell: miRNA OD std dev 0.2023
Cell: miRNA OD max 0.8602
Cell: miRNA OD min -0.0529

Cytoplasm: Hematoxylin OD ... -0.0413
Cytoplasm: Hematoxylin OD ... 0.1135
Cytoplasm: Hematoxylin OD ... 0.5156

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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5. Run the positive cell detection module and try different threshold values. The following figures display the output for
the threshold values previously described. Cells within the same class display the same color.

4 & 'M Y_"§ i3 "
E & P55 '\ :

6. Use the detection measurement table to export the results as probe mean OD per cell. These results can be plotted
as histograms and compared across samples. You can also export the class of each cell, allowing you to count the
cells within each class. The results can be compared across images based on the percentage of cells within each

class.

Fluorescent RNAscope™ image analysis

Before analyzing your image, ensure that the staining is within the linear range based on exposure time (for example,
signal should not be oversaturated). To compare staining intensity between samples, we recommend using the same

exposure time on all slides.
Note: Maximum projection images may work better than single plane images for dot detection.

The following steps describe a general workflow to analyze fluorescent RNAscope™ images. We recommend creating
project for your images before you begin the analysis so you can save the analysis settings and annotations for all the
images in the project to the project folder.

Create a project and import images
1. To create a project, go to File = project - create new project and select a folder to save this project.
2. Import your images using File = open or by dragging the files onto QuPath’s main window. You can see the list of
your images under the project tab.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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3. During the import process, QuPath should automatically set the image type as Fluorescent. If not, double-click on the
Image type tab, and set Image type to Fluorescence in the drop-down menu.

Image = Annotations

¥ Properties

Mame

Path

Image type Fluorescence B Imagetype >

Bit depth

Magnification 2 @ Set image type
Width 2 f )

Bio-Formats

4. Double-click an image in your list to open it in the viewer.
5. Click on the Image tab to find a list of the image properties.

Sef image display

QuPath automatically sets the fluorescent image display as “auto”, which can be misleading when comparing signal
intensity among different images.

1. To reset the image display, go to View > Brightness/Contrast (Shift+C) or click on the - icon on the tab panel.

File Edit Tools | Wiew Objects TMA  Measure  Automate

Shift+C

Ctrl+Alt+Shift+5

2. Highlight the channel you want to adjust by clicking on the channel.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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3. To adjust the Minimum and Maximum display, double-click on either Min display or Max display to manually input
a number or drag the slide bar in the histogram to achieve the optimal visual display. See the following figure for
an example.

Selected

v
B Display range *

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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4. To perform the next steps, use a QuPath annotation tool to select a region. To analyze the whole slide, select the
whole tissue.

Cell segmentation

1. To perform cell segmentation, go to Analyze -> Cell detection > Cell detection.

culate fea

Cell analysis

unts (brightfield)

2. Adjust the threshold under Intensity Parameters to maximize the detection results. Watershed cell detection uses the
intensity threshold to identify cell nuclei.
3. Start with the default settings as shown in the following figure.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
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4. Choose a detection channel for nucleus detection. In the following example, DAPI staining is in channel 1.

B Watershed cell detection O *

Setup parameters

se detection channel 1

ested pis

Nucleus parameters

Minimum area
Maximum area

Intensity parameters

y shape

Cell parameters

5. Click Run, and visually inspect the results of the cell detection. An example of good detection is shown in the
following image.

6. For suboptimal results, first adjust the Threshold value under Intensity parameters. If the value is too high, nuclei are
not detected. If the value is too low, more false positives are detected.
a. To check the intensity values in the DAPI channel, hover the cursor over the nucleus to display the pixel values
on the bottom right of the viewer.
b. Move the cursor over the nuclear boundary to obtain an estimate to use for the Threshold value.
7. If adjusting the Threshold value does not work, adjust other parameters as follows:
e To remove noise, increase the median filter radius.

e To capture more faintly stained nuclei, increase the background radius parameter.

QuPath Analysis Guidelines MK 51-154/Rev A/Date 12/21/2020
23



AED

TECHNICAL NOTE
a bietechne brand
Probe defection

1. For probe detection, use the subcellular defection module. Go to Analyze > Cell detection > Subcellular detection
(experimental).

Automate | Analyze

‘ Subcellular detection (experimental)

{‘ Watershed nucleus d (OpenCV, experimental)

counts (brightfield)

2. Adjust the Detection threshold of all the channels so that detection occurs interactively. In the following example, the
detection thresholds of channel 2 and channel 3 are 35 and 70, respectively.
a. Leave the Detection threshold of the channel(s) not to be detected, such as the DAPI channel, as -1.

b. To estimate the pixel intensity, move the cursor over the dots and note the number displayed at the bottom
right of the viewer.

c. Start with one value and inspect the results, then adjust until most probe dots are detected.

B Subcellular spot detection m} x
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A zoomed example of probe detection (red circles) is shown in the following image. Only one channel is shown.

rva

7 )
Q‘
(R
QC probe defection resulls

1. During the process of optimizing the probe detection parameters, you can inspect the defection results detection by
reviewing the measurements using Show detection measurements.

TMA measurements
Show annotation measurements
Show detection measurements

A table of cell by cell measurements results, including the number of probe copies detected within each cell. For an
example, see the following highlighted measurement for a cell with 17 probe copies.

um  Nucleus: Area Nucleus: Perimeter Nucleus: Circularity Nucleus

2. Double-click on a measurement in the table to highlight the linked cell in the image.
3. Compare the number of detected probes in the table to the number of copies seen visually in the cell and change
the parameters until they match.
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Measurements

The cell measurement table allows you to view the measurements as histograms for the whole region (see the following
example). You can export the results by selecting the table and copying to other data analysis tools, such as an Excel
spreadsheet, for further analysis.

B Detection results - Polr2a_Opal570_Scan1 O *

Centroid Xpm  Cent

PathCellObject 28871

Measurement

Column filter

To script the workflow, see Scripting the workflow on page 12. You can batch export annotation measurements in a project
using the script here.
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