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Chapter 1. Product Information 

 

IMPORTANT! We recommend reading the entire user manual before using the software. 

About this guide 

This user manual provides guidelines and steps for using the RNAscope® HiPlex Image Registration Software 
(Cat. No. 300065). Refer to the RNAscope® HiPlex Reagent Kit User Manual (Doc. No. 324100-USM) to 
use RNAscope® HiPlex detection kits to detect target RNAs and image your tissue samples.  

Visit www.acdbio.com/technical-support/user-manuals to download user manuals. 

Product description  

Background 

You can use the RNAscope® HiPlex Image Registration Software to register and merge the images you have 
acquired after performing the RNAscope® HiPlex Assay, which can simultaneously visualize up to 12 different 
RNA targets per cell in samples mounted on slides. The assay is based on ACD’s patented signal 
amplification and background suppression technology and incorporates multiplexed signal amplification 
systems, enabling users to investigate expression as well as positional relationship between multiple genes 
within a cellular context. 

Overview 

Detecting up to 12 different RNA targets in the same tissue section requires combining the RNAscope® 

HiPlex8 Reagent Kit (Cat. No. 324100) with the RNAscope® HiPlex12 Ancillary Kit (Cat. No. 324140). 
The assay uses the cleavable versions of the fluorophores (AF488, Atto550, Atto647 and AF750) to detect 
four targets at a time. Three rounds of target detection and imaging using an epifluorescence microscope with 
the appropriate filters are performed to detect all 12 different targets. For a more in-depth overview of the 
RNAscope® HiPlex Assay, refer to the RNAscope® HiPlex Reagent Kit User Manual (Doc. No. 324100-
USM).  

After you have acquired your images, you can use the RNAscope® HiPlex Image Registration Software to 
merge/register your images together. Because you are performing two or three rounds of detection and 
imaging, we recommend including the initials R1 (round 1), R2 (round 2), R3 (round 3) and the target names 
when saving image files. Implementing a naming convention will help you identify each group of images 
during the image registration process. The registration process involves generating transformation matrix files 
(*.tfm) using single DAPI channel images to serve as references to register the rest of the single channel 
images. You will either generate one or two files depending on the number of detection rounds performed 
and the number of DAPI images acquired. The first DAPI image you open in the software will serve as a 
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“default” reference image for the second DAPI image, generating a single transformation matrix file. If you 
have completed a third round of detection, a second file is generated when the third DAPI image is aligned 
with respect to the first DAPI image. Once the transformation matrix files are generated, you will apply them to 
your single channel images. The *.tfm files will not be applied to any of the reference images. Once all of 
your images have been merged, you can analyze the composite image and investigate the expression of 
your target RNAs. 

If you have any questions, contact technical support at support.acd@bio-techne.com. 

Software license 

The RNAscope® HiPlex Image Registration Software is available by download from the link obtained from 
ACD.  

  

mailto:support.acd@bio-techne.com


 

RNAscope® HiPlex Software User Manual 300065-UM/Rev B/Effective Date 07102019 
6 

 

Chapter 2. Before You Begin 

Before using the software to merge your images, keep the following considerations in mind.  

Important considerations 

• After you have acquired your images, name your files carefully. Because you are performing two or 
three rounds of detection and imaging, we recommend including the initials R1 (round 1), R2 (round 
2), R3 (round 3), and the target names when saving image files. Implementing a naming convention 
will help you identify each group of images during the image registration process. 

• Make sure that your input images are single channel and in the “Tag Image File Format (tiff)” file 
format (gray scale or pseudo colored). You should have five images per round (DAPI, AF488, 
Atto550, Atto647N, and AF750). Make sure that single channel images do not have DAPI 
overlaid.  

• All input images should have the same resolution and pixel by pixel dimensions. The RNAscope® 
HiPlex image registration software cannot register a cropped image to an uncropped image. Make 
sure that images do not have a scale bar.  

• RNAscope® HiPlex Image Registration software can handle images of any size, but larger images 
take longer to process and view. To achieve faster performance, we recommend processing a field 
of view of no more than 1024 x1024 pixels.  

• For best results, we recommend having an overlap of about 70% between your images.  

• For best registration accuracy, make sure that the DAPI channel images are similarly exposed as your 
other images (the intensity profile of the nuclei is similar). You may have to adjust the exposure to 
achieve similarly exposed images. Overexposure could affect the nuclear size and shape, resulting in 
registration failure due to a mismatch of the nuclear boundary.  

• The registration process involves generating transformation matrix files (*.tfm) using single channel 
DAPI images that serve as references to register the rest of the single channel images.  

• The first DAPI image that you open in the software serves as a “default” reference image for the DAPI 
from all other rounds. 

• You will either generate one or two *tfm files depending on the number of detection rounds 
performed and the number of DAPI images acquired. The *tfm file is a data file that is used to align 
all the other channels since the data points in a single round are already aligned to DAPI staining.  

• Once the transformation matrix files are generated, apply them to your single channel images. The 
*.tfm files are not applied to any of the reference images from Round1. Once all of your images 
have been merged, you can analyze the composite image and expression of your target RNAs. 

  

2 
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Image Registration Software Menu 

 

This chapter describes the basic functions available in the RNAscope® HiPlex Image Registration Software.  

File menu 

The following options are available under the File menu.  

Open  

Use this option to browse to the source folder containing your image files. If any files are already open in the 
software, this option overwrites the current list.    

Add Images to Current List 

Use this option to add additional files to the current list of open images. The new files are added to the end 
of the list. 

Save Images  

Select one of the following options under the Save Images menu:   

• Choose Save All Images (Gray) to save each image separately as a single-channel, gray scale image.  

• Choose Save All Images (Color) to save each image separately as a single-channel, colored image. 
You must pseudo-color your images before selecting this option. 

• Choose Save Checked Images to save the images you have checked as single-channel, gray scale 
images.  

• Choose Save Composite Image to save the current displayed image as a single, composite RGB 
image.  

Exit 

Use this option to quit the software without saving any information. 

Edit menu 

The following options are available under the Edit menu.  

3 



 

RNAscope® HiPlex Software User Manual 300065-UM/Rev B/Effective Date 07102019 
8 

Select All 

Use this option to select all of the images that are open in the RNAscope® HiPlex Image Registration software. 

Unselect All 

Use this option to deselect all of the images in the list of open files.  

Remove Selected Images 

Use this option to remove the selected images from the list of open files.   

Register menu 

The following options are available under the Register menu. 

Register DAPI Images 

Use this function to register selected DAPI images and write the transformation matrix. This is the essential first 
step for generating a multiplex image.  

Apply Registration Transform 

Use this function to apply your generated registration transformation matrix on selected single-channel images. 

Crop Overlapping Region  

Use this option after you have registered all single-channel images to apply the transformation matrix to all of 
the images in the list. No image selection is needed. 

Help menu 

The following options are available under the Help menu. 

User’s Guide 

The software user manual is available under this option, and you can refer to detailed steps. 

Sample Images 

Use this function to review the sample images provide by ACD. This feature enables you to familiarize with 
the workflow of the RNAscope® HiPlex Image Registration. You can use the R1_DAPI, R2_DAPI, and R3_DAPI 
samples images to generate the transformation matrix then later apply the matrix to single-channel images 
from Round 2 and Round 3.  
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Chapter 4. RNAscope® HiPlex Image 
Registration 

Follow the procedure in this chapter to register and merge your RNAscope® HiPlex Assay images. 

Workflow 

Generate transformation matrix files  

 

Apply the transformation matrix to single-channel images 

 

Crop the overlapping region 

 

Select pseudo colors and create a composite image 

 

Save the images 
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Generate registration transformation matrix files 

1. Open the RNAscope® HiPlex Registration software 

2. From the File menu, click on Open.  A pop-up window appears. 

 
3. Open only the DAPI images from each round that need to be registered.  

4. Select all the DAPI images you want to register by checking the box next to each image or clicking 
on Edit > Select All. 
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5. To register your selected images, click on Register > Register DAPI Images. 

 
Create a transformation matrix for aligning DAPI from Round 2 onto DAPI from Round 1. By default, 
the first DAPI image in the list serves as the reference image. All other images will be registered to 
this image. The DAPI registration generates a transformation matrix in the form of a *tfm file.  

6. During registration, a pop-up window displays the file names of the reference image [Reference] 
and the moving image [Moving] being registered.  

 
7. Click on OK to confirm registration and save the transformation file. Later, you will use the 

transformation matrix file to align the corresponding other single-channel images from the [Moving] 
Round onto the [Reference] Round. 
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8. Name the transformation matrix file making sure to indicate which image was merged. The 
software provides you with a suggested file name based on the file name of the original image.  

 
 

9. If you are aligning more than two rounds, you will now be prompted to save a transformation matrix 
that aligns DAPI from Round 3 to the DAPI from Round 1.  

 
10. Click on OK to confirm registration and save the transformation file.  

 
 
 
 
 
 
 
 

11. Name the second transformation matrix file making sure to indicate which image was merged. The 
software provides you with a suggested file name based on the file name of the original image.  

12. The newly registered images appear in the current list of images with “_R” added to the file name 
and a different background color. Make sure the registration was successful by overlaying the 
original DAPI images with the DAPI_R files. If the alignment looks good, continue the registration 
process using the DAPI_R.tif in place of the original DAPI channel images. Overlaying the original 
DAPI files and the DAPI_R files creates redundant DAPI signals. 
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13. Proceed to the next section to use the transformation matrix (*tfm) files created by registering the 

DAPI images to overlay the other single channels (AF488, Atto550, Atto647N and AF750) from 
each imaging round to the reference.  

Apply the transformation matrix to single-channel images 

1. From the File menu, click on Open to browse to and open the source folder containing all of your 
single-channel images. This option overwrites the current list and opens fresh images. Alternatively, 
you can also use Add Images to Current List to open only a few images, which are added to the end 
of the list. 

2. Since Round 1 was used as a reference for all the other rounds, do not apply the transformation 
matrix to any images from Round 1.  

3. To apply the transformation matrix to your Round 2 images, check the boxes next to the Round 2 
single-channel images for DAPI, AF488, Atto550, Atto647, and AF750, and click Register > Apply 
Registration Transform.  
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4. A pop-up window appears prompting you to select the appropriate transformation matrix file. Select 

the *.tfm file that corresponds with Round 2 (where Round 2 DAPI was moving with respect to the 
reference).  

5. Click on Open to apply transformation matrix to all the selected images. When the prompt appears, 
click on OK to confirm the transformation process.  

 
6. The newly registered images appear in the current list of images with “_R” added to the file name 

and a different background color.   
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7. To apply the transformation matrix to your Round 3 images, first uncheck the Round 2 images. 
Check the boxes next to the Round 3 single-channel images for DAPI, AF488, Atto550, Atto647 
and AF750, and click on Register > Apply Registration Transform. 

8. A pop-up window appears prompting you to select the appropriate transformation matrix file. Select 
the *.tfm file that corresponds with Round3 (where Round 3 DAPI was moving with respect to the 
Reference).  

9. Click on Open to apply the transformation matrix to all the selected images. When the prompt 
appears, click on OK to confirm the transformation process.  

10. The software displays the final list of registered images, with an “_R” added to the file name and a 
different background color. 

Crop the overlapping region 

After applying the transformation and while the images are still open, you can automatically crop the 
maximum overlapping region. This change is applied to all of the images in the list, including Round 1 
images.  

1. Click on Register >Crop Overlapping Region.  
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2. All images image files are updated with a  “_C” added to the file name and a different background 
color.  
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Select pseudo colors and create a composite image 

1. Before you save the images, create composite images by selecting multiple channels and applying 
a pseudo color to each individual channel.  

2. Adjust the intensity for each channel using the scale bar below each channel.  

  
 

Save the images  

1.  To save the images, click on File > Save Images.   

2. From the pop-up options menu, choose whether to save each image as gray scale or color.  

 You can choose to save all the images or select the images you want to save.  

 
 

Troubleshooting 

For troubleshooting information, please contact technical support at support.acd@bio-techne.com. 

  

mailto:support.acd@bio-techne.com
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Documentation and support  

Obtaining support 

For the latest services and support information, go to: www.acdbio.com/technical-support/support-overview. 

At the website, you can: 

• Access telephone and fax numbers to contact Technical Support and Sales facilities. 

• Search through frequently asked questions (FAQs). 

• Submit a question directly to Technical Support. 

• Search for user documents, MSDSs, application notes, citations, training videos, and other product 
support documents.  

• Find out information about customer training events. 

Contact information 

Advanced Cell Diagnostics, Inc. 

7707 Gateway Boulevard 

Newark, CA 94560 

Toll Free: 1-877-576-3636 

Direct: 1-510-576-8800 

Fax: 1-510-576-8801 

Information: info.acd@bio-techne.com 

Orders: order.acd@bio-techne.com 

Support Email: support.acd@bio-techne.com 

Limited product warranty 

Advanced Cell Diagnostics, Inc.  and/or its affiliate(s) warrant their products as set forth in the ACD General 
Terms and Conditions of Sale found on the ADC website at www.acdbio.com/store/terms.  If you have any 
questions, please contact Advanced Cell Diagnostics at www.acdbio.com/about/contact. 

http://www.acdbio.com/technical-support/support-overview
mailto:info.acd@bio-techne.com
mailto:order.acd@bio-techne.com
mailto:support.acd@bio-techne.com
http://www.acdbio.com/store/terms
http://www.lifetechnologies.com/termsandconditions
http://www.acdbio.com/about/contact


  

Headquarters 

7707 Gateway Blvd Suite 200, Newark, CA 94545    Phone 1-510-576-8800    Toll Free 1-877-576-3636 

For support, email support.acd@bio-techne.com 

www.acdbio.com 
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